Revision History for PMView versions 3.xx

 

The following bugs and problems are fixed in PMView v3.02:

 

Pressing ALT+F4 in a dialog closes PMView.

The toolbar tooltips are not displayed on Windows XP.

The status bar of the main window and File Open/Save dialogs does not paint correctly when resizing the window.

 

 

 

The following bugs and problems are fixed in PMView v3.01:

 

Zooming may crash PMView.

JPEG files with RGB color space are displayed with the red and blue colors swapped.

There is no way of knowing if PMView is showing the default or actual resolution of a file in the File Info dialog. This version adds the text "(Default)" after the resolution if the actual resolution is unknown.

Minimizing the PMView main window causes the scroll bar positions to be reset to their leftmost/uppermost positions when the window is restored.

The "ExposureTime" field in the EXIF data is sometimes displayed as a fraction "1/10 (sec)" and sometimes as a decimal number "0.10 (sec)". How it is displayed depends on how the camera stored the data. This version of PMView corrects the problem by always displaying it as a fraction regardless of how it is stored.

 

The following features are new in PMView v3.00:

 

EXIF and TIFF/EP support.

New convert function in the File Open dialog that lets you run scripted batch conversions.

Lossless JPEG rotate. This function can be accessed on the Transform menu in PMView's main window and on the File Open dialog object menu. The latter lets you batch transform a number of files.

Support for Windows XP Visual Styles and Themes. The status bar and tool bars are now based on the native Windows Common Controls instead of the custom high-level implementation used in previous versions.

Display resampling: The rendering speed and display quality are much improved. There is a new option on the "Display" page in the Preferences Notebook that lets you select a standard or a high quality filter.

Smooth keyboard scrolling: PMView has a new keyboard scrolling method that makes keyboard scrolling faster and smoother than before.

Function for setting the image resolution (dots per inch or pixels per meter).

File menu: The file menu has new options for copying and moving the currently viewed file.

View/Zoom menu: The View->Zoom menu has a new zoom function "Zoom to Fit" and two new settings for enabling automatic invocation of the function when loading an image. There is also a new "Zoom Lock" option that lets you lock onto the current magnification.

File Open/Save dialogs: New file replace confirmation dialog with thumbnails. This dialog appears depending on the new file copy/move settings found on the Confirmations page in PMView's Preferences Notebook. (You can also change these options directly on the Copy/Move dialogs).

File Open/Save dialogs: New "Copy to..." and "Move to..." commands that let you copy or move files. The new Copy/Move dialog has a list that holds the most recently used directories.

File Open/Save dialogs: New "Print..." command that lets you print one or more files.

File Open/Save dialogs: Optional file "info tip" that shows information for the file under the mouse pointer.

File Open/Save dialogs: The image information dialog has been improved.

File Open/Save dialogs: New sort option that tells PMView to sort files so that damaged files show up first in the file list.

File Open/Save dialogs: New functions for changing the time stamp to the creation date, current date or to the time information stored in EXIF data.

File information: Display of EXIF (v2.2) and TIFF/EP data. Additionally a lot of other information can be displayed including JFIF comments and advanced TIFF tag data.

Transform/Size: New letter/pillar box option that lets you resize an image to any size and keep the image proportional while letter or pillar boxing the image.

Loading/Saving JPEG: Embedded EXIF data will be preserved when saving a file. The JPEG save options dialog has a new option that lets you enable/disable this feature.

Loading/Saving TIFF: Embedded EXIF data and TIFF/EP data will be preserved when saving a file.

Loading, TIFF: TIFF files having old-style JPEG compression (type 6) can now be read.

Loading, TIFF: TIFF files having 32 or 64-bit IEEE floating point image data can now be read.

Loading, FAX: The algorithm for detecting and reading raw G3 FAX files has been improved.

Saving, PCX: There is a new option for enabling/disabling saving of 24-bit files in PCX format.

Display options: The display gamma can now be set on the "Display" page in the Preferences Notebook.

File Open/Save dialogs: The loading speed of on-the-fly thumbnails for JPEG files is improved.

General: New "Use Idle time priority" option on the "Special" page in PMView's Preferences Notebook. This option is on by default.

General: Tip of the Day dialog added.

General: Option for disabling the dynamic PMView program icon, i.e. locking it to always show the standard program icon instead of the currently loaded file.

Command line: New command line option /PRINT that lets you print the specified file(s).

Command line: New command line option /SCRIPT that lets you run a scripted batch conversion on the specified file(s).

Palette Editor: The palette editor displays the value in HTML color format (6-digit RGB hexadecimal).

Preferences notebook: Apply button that lets you apply a change on the fly without closing the notebook.

 

The following bugs and problems are fixed in PMView v3.00:

 

Loading, TIFF: Saving and reading of TIFF/Deflate compression has been updated in accordance with the Adobe Photoshop TIFF Technical Notes dated March 22, 2002.

Loading, TIFF: PMView does not refresh the screen correctly when loading tiled TIFF files having a bottom to top orientation.

Loading, TIFF: TIFF files having a 90 degree rotated orientation are not rotated accordingly by PMView. (PMView ignores the orientation).

Loading, TIFF: Tiled TIFF files having right to left orientation do not load correctly.

Loading, TIFF: CCITT FAX files containing bad fax lines are only partly displayed. PMView stops reading the file at the first bad fax line.

Loading, BMP: Windows bitmaps having bad data in BI_BITFIELDS cause PMView to crash.

Loading, BMP: Adobe Photoshop 7 generates Windows bitmaps that are not compliant with Microsoft's bitmap file specification. Unfortunately the standard non-compliance is of such nature that it breaks Microsoft's recommendation for reading BMP files and thus also makes PMView unable to read the files. This version adds a workaround for coping with these invalid files while still following the recommendations.

Loading, SFF: Damaged SFF files cannot be read although the damage is only minor (for example a few missing lines at the end).

Loading, IFF: Added read/write support for DPI (image resolution) tag.

Loading, UUE/PCX: Loading a UU-Encoded 8-bit PCX file results in a completely black image on deep color systems.

Loading, GIF: When PMView is loading an animated GIF, the file is locked and cannot be deleted.

Saving, Windows BMP: Windows bitmaps saved by PMView cannot be read by Borland Delphi and other applications that use the biClrUsed BITMAPINFOHEADER field to calculate the bitmap data offset.

Saving, ZIP-in-TIFF: Saving the same image over and over again produces output files of varying size. Occasionally, depending on the input image, the saved file is corrupt and cannot be read back with PMView.

General: A painting error may appear when using screen resampling and zooming the viewed image more than 200%.

General: When using the option "Zoom image to fit window", the image sometimes is zoomed to a size that is a few pixels smaller than the window.

General: Using the function "File->New->PMView Window" to create a new PMView window may result in that some files are locked.

Transform/Size: Shrinking a grayscale image results in a deep color image.

File Sequencer: If a custom filter e.g. "Summer*.jpg" is used in the File Open window, the file sequencer will not use it. Consequently, the files presented when pressing PgUp/PgDn in the main window do not correspond to the list of files displayed by the File Open window. This problem was solved by adding the new "<Custom>" type to the list of file filters in the File Open window.

Filters: PMView always defaults to the first filter in the list instead of defaulting to the most recently used filter.

File Open/Save dialogs: File scanning and thumbnail loading stops if PMView is unable to retrieve basic information for a file.

File Open/Save dialogs: The file mask "*.*" does not work according to DOS conventions. It works in a Unix like manner and masks out any file not containing at least one dot. This is considered a bug since the File Open/Save dialogs itself uses "*.*" as file filter when selecting "All Files" in the file type selector. (This bug was introduced by the multiple dot bug fix in PMView v2.32 and did not exist in earlier versions).

File Open/Save dialogs: A file mask like "*.tif;*.jpg;;*.gif" does not list "*.gif" files. (The problem is that a repeated semicolon truncates the mask).

File Open/Save dialogs: Renaming the currently active folder renders drag & drop inoperable (dragging and dropping files will still use the old name which of course will not work).

File Open/Save dialogs: If there is only one file in the File Save window container, clicking on the file does not copy its name to the "Save file name" field.

File Open/Save dialogs: Pressing Esc during a swipe selection does not cancel the swipe.

File Open/Save dialogs: Renaming a folder causes all subfolders of the renamed folder to become defunct until the File Open dialog is closed and reopened.

File Open/Save dialogs: The drive tree will now expand UNC path names containing shared folders.

File Open/Save dialogs: When creating a new folder in a directory that contains a large number of existing folders, the new folder is not scrolled into view.

File Open/Save dialogs: Entering a file name or path into the "Open file name:" field does not work correctly. (This problem appears under Windows 2000/XP only).

General: Pressing the enter or escape key does not work when the focus is on a slider control.

General: Pressing a mnemonic key does not work when the focus is on an editable combo box.

General: PMView does not use the system font setting for the status bar font.

General: Pressing 'Esc' and 'Enter' does not work in some of the dialogs.

Edit Palette dialog: The index control in the palette edit dialog is not CUA compliant. (The keyboard cannot be used to change index).

 

Other changes in PMView v3.00:

 

The behavior of the command line flags /RED, /GRE, /BLU, /BRI, /CON, /COL, /NEG, and /GAM is changed. In previous versions of PMView these flags caused the image data of a loaded image to change. Consequently, the change was applied when saving the image. For example, using PMView with /GAM=1.2 caused the image to become brighter and brighter every time it was saved. In this version, the flags now only affect how the image is painted to the screen.

The command line flags /PAL and /NOP for overriding the palette manager setting have been removed. The palette manager can still be enabled/disabled with the option in PMView's Preferences Notebook.

The command line flag /NOH for disabling PMView's online help has been removed. This version of PMView will always load the online help.

The command line flag /FIL for specifying where filter files reside has been removed. The location of filters can still be controlled through the PMVIEW_FILTER environment variable.

Preferences Notebook: The low color option pages Palette and Color have been consolidated into one page. This page is now hidden on deep color systems.

Preferences Notebook: The "Use Shadow Bitmap" option is removed.

 

Revision history for PMView v2.xx