Revision history for PMView v2.xx

 

The following bugs and problems are fixed in PMView v2.32:

 

Loading BMP: Black & White 1-bit BMP files without color map load as completely black in PMView.

Loading TIFF: TIFF-in-JPEG files having YCbCr photometric with only one sample per pixel cannot be loaded.

Edit/Paste: Pasting a color mapped selection into a color mapped image causes incorrect information on the status bar showing that the image has zero (0) color indexes.

Toolbar: When clicking twice quickly on the toolbar buttons, one of the clicks is missed.

Slideshow: When clicking twice quickly on the slideshow controller buttons, one of the clicks is missed.

Open/Save dialogs: File names with multiple consecutive dots (e.g. "test..jpg") are not included in the file list when using "*.jpg" as file mask.

File Open/Save dialogs: Using multiple asterisks (e.g. "*.*.*") in a file mask does not work correctly.

Color conversion dialog: Typing in a larger value than 256 in the "Convert to Indexed 256-color" dialog causes PMView to crash.

Printing: When changing the value of the number of copies, the new setting is not effective until the print dialog is closed and reopened.

 

-------------------------------------------------------

 

The following bugs and problems are fixed in PMView v2.31:

 

File Open/Save dialogs: When loading a file, the PMView main window does not get the focus and stays below the File Open dialog although the "Float on top" option is disabled (unchecked).

Slideshow: The slide options dialog has the wrong frame style.

Printing: Printing of low-resolution (98dpi) multi-page TIFF/FAX files does not work correctly. (Only the current page is correctly printed).

 

-------------------------------------------------------

 

The following features are new in PMView v2.30:

 

SFF (Structured Fax File) file format support (read/write)

Playback of Animated GIF files

 

 

The following bugs and problems are fixed in PMView v2.30:

 

File Sequencer: Using PgUp/PgDn in PMView's main window when the most recently viewed file has been deleted may cause PMView to crash.

Printing: When the print unit is set to inches or millimeters the minimum printable size is restricted to 1 inch or 1 millimeter respectively.

File Open/Save dialogs: Deselection of files in "Detail" view does not work correctly when the "Sticky Select" option is enabled. (When you click on a file it is selected, but a second click on the same file does not deselect it).

File Open/Save dialogs: When opening the dialog, PMView tries to access the diskette drive. (This behavior/problem was not present in versions prior to v2.14)

File Open/Save dialogs: Dragging files and dropping them back in the source folder causes PMView to crash (Win95/98/ME).

Slideshow: Selecting multiple files in the "File Open" dialog and pressing "Open" to create a slideshow causes the main window to lose focus.

General: If PMView is installed in a folder that contains spaces in the folder name, there will be an error message in new windows launched with the "File->New->PMView Window" function.

 

-------------------------------------------------------

 

The following features are new in PMView v2.20:

 

File Sequencer: The file sequencer (PgUp/PgDn in PMView's main window) now follows the sort order and file filter selected in the File Open dialog.

File Sequencer: New option that lets you choose whether the file sequencer file list should be automatically refreshed or not. This option is located under "FileNext/PreviousFile ListKeep Refreshed".

File Open/Save dialogs: The "Open file:" entry field is changed to a drop-down combo box that holds a list of the 50 most recently used directories.

File Open/Save dialogs: Automatic addition and removal of attached/detached disk drives in the folder tree.

Printing: PMView now supports printing of all pages in a multi page file (e.g. TIFF). A range selector has been added to the print dialog for selecting what page range to print.

Print dialog: New option for setting the number of copies to print.

Print dialog: The print dialog has been made more user friendly by replacing the three "Fit" pushbuttons with a list box that lets you select the option you want. The new design allows "Fit page" to work as most users expect and always automatically fit the image to the page (for instance when a margin or the orientation is altered).

Display quality: Added dithering in 15 and 16 bit video modes. This addition eliminates visible color stairs in the image.

Display quality: New improved ordered dithering gives better image quality in video modes that use 256 colors.

Saving, TIFF: New TIFF save option that lets you save TIFF files with only one single data strip. (Some FAX applications require this).

General: New option that lets you select whether deleted files should be moved to the Recycle Bin or not. This option is located on the "Special" page in PMView's Preferences Notebook.

 

 

The following bugs and problems are fixed in PMView v2.20:

 

File Open/Save dialogs: Unreasonably slow performance when having more than 10,000 files in the same directory.

File Open/Save dialogs: The folder tree does not work correctly with keyboard input. If 'O' is pressed in the file open dialog, PMView will try to open a file instead of changing to the first directory with a name that starts with an 'O'. The same problem also appears with the 'S' key in the file save dialog.

File Open/Save dialogs: Double-clicking on a file's file name does not work correctly. Instead of opening the clicked file, the double-click does the same thing as a single click does, i.e. a file rename operation.

File Open/Save dialogs: The reference file in the FOC is not changed when loading new files with the PgUp/PgDn keys in the main window. Thus, pressing the SHIFT key and clicking on a file does not give the expected selection. Instead of using the currently selected (highlighted) file as reference, the file that was most recently selected by the user is used as reference.

File Open/Save dialogs: Pressing F5 to refresh does not add new drives nor does it remove deleted drives.

File Open/Save dialogs, batch conversion: In case the format conversion of a file for some reason fails the template file is not deleted. This may happen for instance if the source file is corrupt or if the file is not a valid image file.

File Open/Save dialogs: Container view options are not stored separately for the Open and Save dialogs. (Both dialogs use the same registry settings.)

Loading, DCX: PMView cannot read 8-bit DCX files with more than 1 page.

Loading, TIFF: PMView will now read 1-bit TIFF files that are missing the required tag 252 (Photometric Interpretation).

Loading, TIFF: PMView will now read TIFF files with invalid data in tags 279 (StripByteCounts) or 325 (TileByteCounts).

Printing: Printing large images on Win95/98/ME fails with no printer output.

General: Error tracing with the /LOG command line switch does not work correctly under Windows 95/98/ME.

On-line help: Several errors and omissions in the on-line help are fixed.

 

-------------------------------------------------------

 

The following features are new in PMView v2.14:

 

New menu option "File->Next/Previous->Wrap" that lets you select if PMView's File Sequencer should wrap at the last/first file or not.

 

 

The following bugs and problems are fixed in PMView v2.14:

 

Pressing ALT twice in the main window causes the status bar to go blank.

File Open/Save dialogs: It is not possible to rename or delete folders. The menu entries for these functions are grayed out. (This problem appears under Windows 2000 only).

The "Copy" and "Preserve Color Depth" menu items in the "Edit" menu use the same mnemonic character.

 

-------------------------------------------------------

 

The following bugs and problems are fixed in PMView v2.13:

 

PMView does not ask for save confirmation if its File Save dialog is open.

Dragging files and dropping them back in the source folder gives an error message.

The folder list in the File Open/Save dialog does not auto scroll during drag & drop.

 

-------------------------------------------------------

 

The following features are new in PMView v2.12:

 

New menu option "View -> Show -> Window Borders" that lets you hide the window borders of PMView's main window.

 

The following bugs and problems are fixed in PMView v2.12:

 

Convert to Black & White: Conversion of a Deep Color image results in an image that PMView internally still thinks is Deep Color. Saving this file results in a Deep Color image instead of a Black & White 1-bit image.

File Open dialog: File open dialog opens with no files.

General: Fixed a problem with entering the decimal separator in entry fields.

General: Some files cause PMView to crash.

About dialog: The About dialog does not display the version number of PMView.

 

-------------------------------------------------------

 

The following features are new in PMView v2.10:

WBMP (WAP Bitmap) file support (read/write)

PIC (Softimage Picture) file support (read/write)

Threshold control for Black/White conversion

PMView's System Info dialog now includes the version and internal build number of PMView.

PMView now comes with WinHelp 2000. (The OS/2 IPF help has been replaced with a native Win32 help system).

 

 

The following bugs and problems are fixed in PMView v2.10:

Loading, JPEG: Some recovered JPEG (non-JFIF) files do not load because they are mistaken for FAX G3 files. The detection of FAX G3 is too lenient. The requirement is increased from a 10 line minimum to a 100 line minimum for G3 files.

Loading, Windows BMP: Loading a Win32 BI_BITFILEDS type bitmap file results in incorrect colors (interchanged red/blue color components).

Loading, TIFF: Some TIFF files using Packbits compression cannot be read. PMView refuses to read files that are incorrectly stored with scanlines that decode into too many bytes. This is now fixed so that PMView is more lenient in its error checking and accepts such TIFF files.

Saving, Windows BMP: Windows BMP files saved with PMView has an error in the file header.

Saving, EPS:. PMView generates an incorrect BoundingBox and scale factor.

Zooming: Zooming to the minimum or maximum limit causes the zoom to get stuck at either limit.

Zooming: Zooming intermittently crashes PMView.

Slideshow: Closing a slideshow disables the file sequencer (File->Next/Previous).

Printing: Printing on a printer that uses different horizontal and vertical resolution results in a stretched image.

Brightness/Contrast/Color dialog: Contrast adjustment algorithm improved.

Tool bar: The tool bar icons remain grayed-out after applying a transform to an image.

File Save dialog: When saving a new image (not existing on disk yet), PMView correctly opens the save dialog with the last folder saved to highlighted in the directory tree. However, the container does not show the contents of this directory.

File Open/Save dialogs: The disk free/total space indicator displays an incorrect value on Win95/98 when the total disk space exceeds 2GB.

TWAIN: The thread priority of PMView's main window interferes with the priority of the interfacing application and causes slow TWAIN performance.

Multi monitor support issues corrected.