Printable Version of Topic

Click here to view this topic in its original format

PMView Pro Forums _ PMView - OS/2 Technical Support _ V3.24: Foc Convert And Current Dir

Posted by: Al Savage Mar 22 2006, 12:05 AM

Conversion Scripts: When using a relative path in a conversion script, the path is resolved with reference to the current directory of the command line. While this works as expected when running PMView scripts from the command line, the behavior may seem odd and confusing to users launching the script directly from the main menu or from the FOC popup menu. This version changes the behavior so that relative paths are resolved relative to the FOC directory. When running scripts from the command line, the behavior remains unchanged.

I just had an opportunity to try to use this. In the screenshot below of an error dialog that popped in the FOC, the dir


does exist, and is the what the FOC is showing. I selected five files, RMB and selected Convert, and for the Output Directory I typed "work" by itself (w/o quotes).

(Earlier, I'd tried ".\work" which failed oddly, you may want to test for yourself. It should resolve but doesn't, and PMV then shows the faulty path as
which clearly isn't what is intended.)


Freespace on K: is 27GiB, and it's not write-protected.

Al S.

Posted by: Al Savage Mar 22 2006, 11:32 PM

Also, after a failed convert, and after I'd cleared any dialogue, the affected FOC thumbnails have remained as grey "Converting" blocks. They didn't revert to thumbnails of the images.

Al S.

Posted by: Peter Mar 30 2006, 07:51 PM


Does the "work" directory exist? PMView scripts WILL NOT CREATE directories. The target directory has to exist.

FWIW, the following directories are all identical:


All refer to \test\work on the d: drive.


Posted by: asavage Apr 2 2006, 11:41 AM

QUOTE (Peter @ Mar 30 2006, 07:51 PM)
PMView scripts WILL NOT CREATE directories.

That was the info I was missing.

PMV v3.20 Convert DOES CREATE directores:

(the directory to be created is "work")

Unfortunately, it creates them off the program directory, instead of the selected FOC directory:

Apparently, the location of where a FOC Convert script will originate the script's path has been repaired, but its ability to create a directory has been removed.

Al S.

Posted by: Peter Apr 2 2006, 08:51 PM


I'll look into this.


Posted by: asavage Apr 3 2006, 12:42 AM

Another thing I found tonight:

FOC, select a thumbnail, RMB and select "Copy to", for Target directoy type '.', (for filename, I changed it), the copy operation put the file in the PMV program directory, just like Convert used to do.

Did you fix only scripts for relative paths? I expected the Copy to '.' to copy the file to the directory that the FOC is showing me.

Posted by: Peter Apr 3 2006, 09:37 PM

Yes, I only fixed it for the script function...

You're of course right that copy/move should behave the same way! Thanks for pointing out this issue.


Powered by Invision Power Board (
© Invision Power Services (