Help - Search - Members - Calendar
Full Version: Interpolation slower from Pentium3 -> 4
PMView Pro Forums > PMView Pro Discussion > PMView - Windows Technical Support
Anonymous
Hi Peter,
I've recently upgraded my Windows 2000 Professional system from a

> Pentium 3-500MHz with 512MB of RAM

to

> Pentium 4-1.5GHz with 1.5GB of RAM

and noticed that interpolation of larger images has slowed drastically. I have tried upgrading to the latest version (v2.31), to no avail - interpolation under the supposedly slower system was smooth and faster.

Under the Pentium 4 system, PMView interpolates larger images in a choppy manner, and is at least a magnitude slower to complete the render.

Any ideas?

Thanks,

- Wade
Peter
This sounds very strange. I'd say that there might be something odd with your L1/L2 cache settings. What cache size did your Pentium III have? How about the P4?

Or is this maybe just a display driver issue? Is the rendering choppy also when you disable interpolation?

------------------
Peter Nielsen (peter@pmview.com) "If you can dream it, you can do it" JFK.

[This message has been edited by Peter (edited December 08, 2001).]
Anonymous
QUOTE
Originally posted by Peter:
[b:post_uid0]This sounds very strange. I'd say that there might be something odd with your L1/L2 cache settings. What cache size did your Pentium III have? How about the P4?

Or is this maybe just a display driver issue? Is the rendering choppy also when you disable interpolation?
[/b:post_uid0]


Thanks for your reply, Peter - the cache settings are equivalent across both processors. I am using SDRAM with the P4 (on an Asus P$ mainboard), if it makes any difference.

When I disable interpolation, the jagged edges occur in some images which are sized down to the display resolution (1024x768), but no artifacts, etc. are evident.

Are there libraries or settings from past PMView installs which may affect the rendering engine? This system is using the latest ATI All-in-One Radeon drivers for Windows 2000.

Thanks,

- Wade
Peter
QUOTE
Originally posted by wader:
[b:post_uid0]When I disable interpolation, the jagged edges occur in some images which are sized down to the display resolution (1024x768), but no artifacts, etc. are evident.[/b:post_uid0]


Is the rendering fast in this case, or is it still slower than on your old system? If it's still slow, then there's something odd with the display driver on your new system.



------------------
Peter Nielsen (peter@pmview.com) "If you can dream it, you can do it" JFK.
Anonymous
Hi Peter - the rendering is fast with interpolation DISABLED. It's only when I turn it on again, that I see the images rendered to the screen in sections (i.e., not smooth progression), and much slower than on my prior Pentium 3, 500MHz.

- wader
Anonymous
BTW, not sure if this was clear, but rendering with Interpolation enabled is fast when the image size is less than the display size. The drastic slowdown occurs only when a larger image than 1024x768 is being resized for the screen. Again, the speed is vastly slower than under a P3 with otherwise same hardware and software.

Hope that helps.

- wader
Peter
This sounds very strange. The only explanation I have is that there is something wrong with the cache management (i.e. an operating system or hardware thing).




------------------
Peter Nielsen (peter@pmview.com) "If you can dream it, you can do it" JFK.
Anonymous
Maybe, though I haven't noticed such problems for anything else yet . Any diagnostics in PMView I can try?

I assume that I'm the only one to report this with a P4 processor - mine is using the Asus P4B mainboard, which uses an Intel 845 chipset, and PC133 SDRAM. DirectX 8.1. Not sure if the libraries you use are at all looking for anything special.

- wader
Anonymous
Peter, I tried some graphics benchmark tests and check the cache settings: everything seems normal outside of PMView, from what I can glean. Cache is 20 for L1 and 256 for L2, btw.

- wader
Peter
Are you sure that you're not running in 256 color mode? (Interpolation is much slower in 256 color mode since a nearest color search must be done for each pixel).

Check that you're using a video mode with deep color (15 bits or more).

Let's hope this is it. At least this would explain why it is significantly slower

------------------
Peter Nielsen (peter@pmview.com) "If you can dream it, you can do it" JFK.

[This message has been edited by Peter (edited December 21, 2001).]
Anonymous
QUOTE
Originally posted by Peter:
[b:post_uid0]. . . (Interpolation is much slower in 256 color mode since a nearest color search must be done for each pixel). . .
[/b:post_uid0]


Peter, good suggestion, but I'm definitely running in 32bit color mode at 1024x768.

Again, it's only when the image is larger than my display resolution that the interpolation is noticeably slow. Very odd, especially since the graphics benchmarks seem to indicate no issues with the Ati card. I suppose this is somehow related to how PMView is working with my 1.5GHz P4 processor, but even though I'm using SDRAM on this Asus P4 motherboard, things shouldn't be slower than under my 600MHz P3 on a P2B motherboard.

I'm stumped.

- wader
Anonymous
Peter,
Would you recommend any types of tests I could run to attempt locating the cause of this problem?

Thanks,

- wader
Peter
Try a 1600x1200 GIF and a 1600x1200 color JPEG.

Do you notice a remarkable difference in speed?



------------------
Peter Nielsen (peter@pmview.com) "If you can dream it, you can do it" JFK.
Anonymous
QUOTE
Originally posted by Peter:
[b:post_uid0]Try a 1600x1200 GIF and a 1600x1200 color JPEG.  

Do you notice a remarkable difference in speed?[/b:post_uid0]


Hi Peter, just saw your helpful reply -

No difference in loading or rendering speed that I could discern. Both took about 4 seconds after I dbl-clicked them from the File Open dialog.

- wader
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.