Help - Search - Members - Calendar
Full Version: PMView doesn't prinet anymore
PMView Pro Forums > PMView Pro Discussion > PMView - Windows Technical Support
Pagni
I'm using PMView since beta versions and I was able to print with any printer with no preblems.

Two weeks ago I tried to print an image on my HP Deskjet but the printing progress bar ran very fast and anything was sent to the printer.

I've made many tests with other printers (Hp Laserjet) and tried to reinstall all my printers drivers and also PMView (deintalling it and reinstalling).

All other applications are printing regularly but PMView does nothing (it doesn't report any error).

Could somebody help me ?

------------------
Ing. Giovanni Pagni
Peter
Did you also DEINSTALL your printer driver? If not, then do this. First deinstall the printer driver and then reinstall it.

If that does not help, then start REGEDIT and delete the HKEY_CURRENT_USER/Software/Nielsen Software/PMView/2.0/Print key and all its subkeys.



------------------
Peter Nielsen (peter@pmview.com) "If you can dream it, you can do it" JFK.
Pagni
I've already tried deleting the registry key and subkeys, but it didn't worked for me.

I'm not shure if I DEINSTALLED the printer dirvers, I'll try this evening.

------------------
Ing. Giovanni Pagni
Pagni
I've tried deinstalling all my printer drivers and then reinstalling them. Unfortunately the problem is still there !!

I can't understand why the other applications are working fine, and only PMView shows this strange behaviour

------------------
Ing. Giovanni Pagni
Peter
QUOTE
Originally posted by Pagni:
[b:post_uid0]I can't understand why the other applications are working fine, and only PMView shows this strange behaviour
[/b:post_uid0]


In order to provide the extended print capabilies, PMView doesn't use the standard print dialog.

Obviously something is broken in your Windows setup, but exactly what, that is the question...

What happens if you press the "Setup..." button in PMView's print dialog? Does it work normally?



------------------
Peter Nielsen (peter@pmview.com) "If you can dream it, you can do it" JFK.
Pagni
Yes, the setup button works fine! Everything is working regularly, the only thing is that the print progress reach the end very very fast and in the printer folder I don't get any priter job (It looks like the printer doesn't receive the job).

Shurely you are right it's something connected to the printer configuration (is it possible that some installed application replaced some system DLL with an older one ? Unfortunately I cannot check this because I don't know wich DLL is involved in the printing process.)

I hope to solve this problem without reinstalling Windows because I have several applications installed, and it will take a lot of time to reinstall everything.

If only I could exploit the enhanced capabilities of my printer under OS/2 ... !!!


------------------
Ing. Giovanni Pagni
Peter
Please e-mail me at pnielsen@abo.fi

I will send you a special debug version that hopefully lets us track down this problem.

Thanks,



------------------
Peter Nielsen (peter@pmview.com) "If you can dream it, you can do it" JFK.
Peter
The problem is identified:

1.The problem discussed here only occurs on Win95/98 (and possibly WinME).
2.The problem appears when trying to print large bitmaps (=bitaps that are much larger than the size of the Windows desktop). Printing small bitmaps works flawlessly.

Reason for problem:

This is a general problem with many Windows 95/98 family printer drivers. They cannot cope with large bitmap transfers.

Solution:

The solution to the problem is to redesign the PMView printing routine to transfer the image in smaller chunks so that no chunk is larger than the current desktop size.

This fix will be included in PMView v2.20 (Estimated availability: Late February 2001)



------------------
Peter Nielsen (peter@pmview.com) "If you can dream it, you can do it" JFK.
Anonymous
I am also seeing this problem, and am glad to see that it is an identified bug and will be remedied.



In case someone reads Peter's message above and doesn't figure it out for themselves, the workaround is to resize (Transform -> Size) your image down until it prints. In my case, a 5100x3304 TIFF had to drop to 2925x1895 before it would print (and not a pixel more). I don't know if color depth is also a factor.



My desktop is sized at 800x600.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.