Welcome Guest ( Log In | Register )

> Pmv 3.17 Blocks On Foc If Last Drive Used Is Unavailable, And sometimes even when it is!
post Mar 16 2013, 05:50 PM
Post #1

Forum Member

Group: Members
Posts: 96
Joined: 6-August 00
From: Duvall, Washington USA
Member No.: 28

I've noticed this in other versions, but it was really apparent today when I installed v3.71

The last time I used PMV, I was using a networked drive for opening files.

When I installed v3.71 today, the network drive was unavailable. Upon <Ctrl+O>, PMV nearly locks the system. I have three installations, and I thought it was PMV locking up, but it would seem to work right up until I opened the FOC.

The first box opened the FOC, and populated it with placeholder icon, but locked up when drawing the thumbnails. The other two wouldn't even draw the FOC; they just became zombied when <Ctrl+O> and the last drive was a non-available network drive. They would not immediately kill via the Tasklist, but given enough time, they did eventually die.

When I rebooted the server (the network resource for image files), and restarted each PMV, they seem to work OK.

I have noticed bad behaviour in the past WRT the FOC and networked drives, sometimes to the point of having to reboot the client box, and at one time this was bad enough that I just didn't use PMV on networked drives, but the last two years this has been less of a problem, though it would still become unresponsive when <Ctrl-O> on a network drive and I'd have to kill & restart it. In those cases, it would always lock up during populating the icons in the right pane; either it wouldn't draw all the placeholders, or it wouldn't finish creating the thumbnails.

I've put off posting about this bug for years, because it seemed like too much work to track down for what I perceived to be an OS/2 networking-related issue, but I have had it happen at least once on a WinXP SP3 box, just last week. I've no idea about how to approach fixing it, but I thought it would be a good idea to document that at least one user is having a problem WRT the FOC and networked drives.

I do 90% of my work with images on an OS/2 server. Lately, I've been doing a lot more than previously, so the frequency of problems is higher.

FOC locks up with 3/4 of the FOC saying "can't create thumbnail" and two icons saying "creating thumbnail". CPU at 100%, mouse moves but is showing an OS/2 clock cursor. I was able to grab a camera and take a picture, as it turns out the box had to be rebooted -- the screen remained unchanged for 30 minutes.

I just updated my WinXP box to v3.71, and saw some odd FOC behaviour too, noted in the second picture below: the left pane does not fully populate all of the mapped drives until about 45 seconds have elapsed.

Here's a couple of pics. If the links don't work, my broadband is down again.
Screenshot via camera: OS/2: box locked up at FOC

Screenshot via camera: WinXP: PMV locked for 45 seconds.

I'm off to backlevel to v3.70 (on the OS/2 boxes at least).

Sidebar for the Win version:
While I'm thinking of it: Win version: when I have a whole lot of files on a network drive and the FOC has generated thumbnails, and I dump a new file in that remote directory via another app, then bring up the FOC and refresh (F5), on the Win box there is no indication that the refresh is occurring.

For example, using PhotoShop, I just put those two pics above in a directory I was working on with PMV. I wanted to bring the PSD file in PMV. I opened the FOC and saw all the existing thumbnails. I pressed <F5>. The new PSD file has a filename which sorts it to the end. It took around ten seconds before the new placeholder icon (and eventually the thumbnail) appeared. During that 10 seconds, there is not user feedback that the refresh is occurring. I, as a long-time user of PMV, am used to this, but every so often I forget to "wait for it", and during this interval I'm thinking that something has gone wrong.

As an enhancement, some kind of visual indication that a refresh is in progress would be a good idea.

Regards, Duvall, WA
Al S.
Go to the top of the page
+Quote Post
Start new topic
post Apr 15 2013, 09:40 AM
Post #2

Forum Member

Group: Members
Posts: 11
Joined: 20-January 06
Member No.: 205

I have had a similar problem. I'm hoping you won't discount it since it is related to a user whose opinion you seem to value. I have extremely large directories under OS/2 and find that I must await PMView's reading of subdirectories before I can again use PMView. But, I need at least a little depth. Is it possible to set it to read a specifici number of directory levels? Too much work? I realize that it may be due to using an underpowered T30 that I'll be upgrading to a W400, or something similar.

Also, I am shocked to hear you talking about stopping development of the OS/2-eCS version. I continue to use it for several hours daily despite the printer problems that you say are not yours to fix, despite my being unable to correct them by reverting to earlier driver revisions. Outside of these fora I only praise PMView. -- Mark
Go to the top of the page
+Quote Post
post Apr 15 2013, 10:18 AM
Post #3

Forum Member

Group: Admin
Posts: 664
Joined: 14-March 00
From: Wilmington, North Carolina
Member No.: 3

QUOTE (Mark_Henigan @ Apr 15 2013, 10:40 AM) *
Is it possible to set it to read a specifici number of directory levels?

PMView only reads one level down - this is done in order to be able to add the [+] to a directory (to visually show that it can be expanded).

If you turn off subdirectory scanning (which should be much faster), you will lose these [+] signs, but you can still double-click on a directory to expand it.

So if you know your directory structure it's definitely worthwhile to turn off sub directory scanning. However, if you're frequently exploring new unknown paths, the [+] is of course much needed.

Peter Nielsen ( "If you can dream it, you can do it" JFK.
Go to the top of the page
+Quote Post
post Apr 16 2013, 12:20 PM
Post #4

Forum Member

Group: Members
Posts: 96
Joined: 6-August 00
From: Duvall, Washington USA
Member No.: 28

Feb 8 2013 is the build date of v3.71. Continue reading the log and you will find the actual logging time

Nothing like displaying my lack of reading skills to the world sad.gif
Are you saying that 3.70 works?

I had been planning to do multiple installations and try to find a version that worked "better", but it's taken me quite a bit of time to just get a decently repeatable testcase, so I haven't.

But, to answer your question: the FOC in versions prior to 3.71 could be counted on to go to 100% CPU utilization when reading from a remote drive about one in ten times (a rough estimate). It was often enough that for a long time I just avoided pointing to the FOC to a non-local drive. I've seen the problem for several years.

Lately, I've been doing a lot more work using PMV -- a lot of manual scanning of large materials. My workflow is to use TAME/SANE to scan to a default local directory, open the scan with PMV, rotate & crop, then save to remote drive. That worked fairly reliably, as the FOC would only read the remote directory once -- the first time I'd navigate there to save, and I found that I could avoid the 100% CPU problem that way.

When I went from 3.70 -> 3.71, that didn't seem to work as well: I was having the 100% CPU problem every day. I first noticed a very bad problem the very first time I installed 3.71, because the remote drive was not available, and the ini saves the last opened dir. So, I'd start 3.71, open FOC, and it would try to open a non-available drive, and it locked up there. I do not recall if it was a 100% CPU issue on that particular case. However, it was the same "locked up" with all three installations of 3.71. I backed all three out to 3.70; later, I figured out the trigger, rebooted the remote server, and reinstalled 3.71.

As long as the "last directory read" is available, the FOC does work reasonably well, as well as 3.70, but it does go to 100% CPU more easily than previous versions.

I've found a close-to-repeatable testcase here: if I have a filter of *.* and Thumbnail type of Icon or Mixed, I can usually get it to trigger if I read a certain directory over and over. It takes a lot of reads, but eventually it will trigger and the CPU will go 100%. On both boxes, different versions of OS/2, same local directories and with fewer than (55) files in each.

That makes it not a networking issue (as I'd thought it was for years), not a specific FP level issue, and not a "too many files to read" issue.

On the eCS box, I have TOP/WatchCat (or whatever it's called) installed by default, and I can kill PMV and resume using the box, although if I do that 3+ times other system problems crop up and I have to reboot that box. Since it's JFS, that's not a big deal: it's a fast reboot.

My scanner box is Warp4, does not have WatchCat/TOP installed, uses HPFS386 drives, and a reboot is nearly 15 minutes due to the slow mount of the drives (HPFS & HPFS386 take a very long time to mount large drives), so when the 100% CPU problems occurs, it severely interrupts my workflow.

I've finally gotten a couple of screenshots, one of each box, of the FOC and the CPU monitor.

(click on any image for larger)

I do have "/log=pmview.log" for both those boxes, but as PMV does not crash --it merely makes the systems unusable -- nothing useful is written to the logs. If there's a way of turning up the log level, I can do that.

I'm typing this on a third box on my network. I've just checked those two boxes whose screenshots I took and processed via CS3, and both are still at 100% CPU and have been for over an hour as I type this. As soon as I submit this post, I'll go reboot them both.

Regards, Duvall, WA
Al S.
Go to the top of the page
+Quote Post

Posts in this topic
- asavage   Pmv 3.17 Blocks On Foc If Last Drive Used Is Unavailable   Mar 16 2013, 05:50 PM
- - asavage   Your forum software does not let me edit the Subje...   Mar 16 2013, 05:52 PM
|- - Peter   QUOTE (asavage @ Mar 16 2013, 05:52 PM) Y...   Mar 26 2013, 10:52 AM
|- - asavage   QUOTE (Peter @ Mar 26 2013, 10:52 AM) The...   Mar 27 2013, 12:04 PM
|- - asavage   On my OS/2 box, it's doing it again right now....   Apr 13 2013, 06:39 PM
|- - Peter   It sounds like you have overlooked a setting: Have...   Apr 13 2013, 06:45 PM
|- - asavage   I'll try that in a moment; I had given up on P...   Apr 13 2013, 07:08 PM
|- - Peter   QUOTE (asavage @ Apr 13 2013, 08:08 PM) I...   Apr 13 2013, 07:13 PM
|- - Peter   QUOTE (asavage @ Apr 13 2013, 08:08 PM) S...   Apr 13 2013, 07:24 PM
- - asavage   I toggled that option off, was able to successfull...   Apr 13 2013, 07:25 PM
|- - Peter   Feb 8 2013 is the build date of v3.71. Continue re...   Apr 13 2013, 07:27 PM
- - Mark_Henigan   I have had a similar problem. I'm hoping you ...   Apr 15 2013, 09:40 AM
|- - Peter   QUOTE (Mark_Henigan @ Apr 15 2013, 10:40 ...   Apr 15 2013, 09:51 AM
|- - Peter   QUOTE (Mark_Henigan @ Apr 15 2013, 10:40 ...   Apr 15 2013, 10:18 AM
|- - asavage   QUOTE Feb 8 2013 is the build date of v3.71. Conti...   Apr 16 2013, 12:20 PM
|- - Peter   QUOTE (asavage @ Apr 16 2013, 01:20 PM) I...   Apr 16 2013, 12:41 PM
|- - asavage   I'd love to be able to hand you a file that tr...   Apr 16 2013, 03:46 PM
|- - Peter   Al, Do you have PMView configured to automaticall...   Apr 16 2013, 04:03 PM
||- - Peter   Try to use <All Formats> instead of <All ...   Apr 16 2013, 04:07 PM
||- - asavage   QUOTE (Peter @ Apr 16 2013, 05:03 PM) Do ...   Apr 16 2013, 04:15 PM
||- - Peter   QUOTE (asavage @ Apr 16 2013, 05:15 PM) T...   Apr 16 2013, 04:43 PM
||- - asavage   QUOTE With "List files of type" set to ...   Apr 16 2013, 05:58 PM
||- - Peter   Another thing worth trying: Set "Icon Thumbna...   Apr 17 2013, 08:37 AM
||- - asavage   With <All Types>, I was unable to trigger 10...   Apr 17 2013, 11:30 AM
||- - asavage   Is there anything else I can do to help narrow-dow...   Apr 18 2013, 10:35 AM
||- - Peter   QUOTE (asavage @ Apr 17 2013, 12:30 PM) W...   Apr 18 2013, 01:14 PM
|- - asavage   QUOTE (asavage @ Apr 16 2013, 04:46 PM) ....   Apr 16 2013, 04:08 PM
|- - asavage   QUOTE (asavage @ Apr 16 2013, 04:46 PM) I...   Apr 18 2013, 01:59 PM
|- - Peter   I just tried to "wander around" the file...   Apr 18 2013, 03:08 PM
|- - Peter   Ok. I found the problem. It was a Microsoft Visual...   Apr 18 2013, 05:03 PM
- - Peter   QUOTE (asavage @ Mar 16 2013, 06:50 PM) I...   Apr 15 2013, 10:03 AM
- - asavage   Bugs squashed are always good, even it it's no...   Apr 18 2013, 08:05 PM
|- - Peter   Very true... I still believe the core problem is t...   Apr 18 2013, 08:14 PM
|- - Peter   Ok, as it turns out, the bug I found only affects ...   Apr 19 2013, 09:50 AM
|- - asavage   QUOTE (Peter @ Apr 19 2013, 10:50 AM) thi...   Apr 19 2013, 11:02 AM
|- - Peter   Al, We also have determined that the problem only...   Apr 19 2013, 11:24 AM
|- - asavage   I thought so, but this morning I was proved wrong....   Apr 19 2013, 12:16 PM
|- - Peter   Ok. Then the next step is to investigate the possi...   Apr 19 2013, 12:21 PM
|- - asavage   QUOTE (Peter @ Apr 19 2013, 01:21 PM) Thu...   Apr 19 2013, 06:07 PM
|- - Peter   QUOTE (asavage @ Apr 19 2013, 07:07 PM) S...   Apr 19 2013, 06:16 PM
|- - asavage   I have caught up on my work for this batch. Anoth...   Apr 19 2013, 07:16 PM
|- - asavage   I had a batch of 128 jpeg files to convert in-plac...   Apr 21 2013, 12:04 PM
|- - Peter   Hmm. Now you threw in TWO new factors at the same ...   Apr 21 2013, 12:07 PM
|- - Peter   Another thing you could try is to disable "Us...   Apr 21 2013, 12:19 PM
- - asavage   I worked with it several hours yesterday, and with...   Apr 30 2013, 12:21 PM
- - Peter   QUOTE (asavage @ Apr 30 2013, 01:21 PM) I...   Apr 30 2013, 12:52 PM
- - Peter   FWIW, this great article may be of some value: h...   Apr 30 2013, 01:21 PM
|- - asavage   QUOTE (Peter @ Apr 30 2013, 01:21 PM) FWI...   May 3 2013, 11:57 PM
|- - Peter   Al, Do you think there's a chance that this p...   Sep 3 2013, 12:35 PM
|- - asavage   QUOTE (Peter @ Sep 3 2013, 12:35 PM) Do y...   Feb 14 2014, 09:50 PM
|- - Peter   Al, It seems like something in your disk system i...   Apr 12 2014, 08:34 AM
- - asavage   QUOTE (Peter @ Apr 30 2013, 12:52 PM) Now...   Apr 30 2013, 01:51 PM
- - Peter   Thanks to your valuable feedback, and after thinki...   Apr 30 2013, 04:02 PM

Reply to this topicStart new topic
3 User(s) are reading this topic (3 Guests and 0 Anonymous Users)
0 Members:


Lo-Fi Version Time is now: 13th November 2018 - 08:08 PM