PMView.com

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Png & Firefox Again, A two-color sample PNG does not display in FF
asavage
post Jun 6 2009, 09:01 PM
Post #1


Forum Member


Group: Members
Posts: 96
Joined: 6-August 00
From: Duvall, Washington USA
Member No.: 28



Sample file:
http://asavage.dyndns.org/ftp/hosting/Suba...ompSystem01.png

I can view this OK using PMV.

However, it displayed as a (scalable) blank white image in FF 3.0.10 (Win XP SP3) and FF 2.0.0.19 (OS/2 W4 FP17).

Seems to display OK under some version of IE.

Before I try to file a bug with Mozilla, can you tell me: is this a fault of FF or the sample image?

File->Info for that sample file:


(Oh, and this forum software screwed up my capitalization in the thread title. It should read, "PNG . . . ", not "Png . . . ".)


--------------------
Regards, Duvall, WA
Al S. http://asavage.dyndns.org
Go to the top of the page
 
+Quote Post
Peter
post Jun 9 2009, 08:13 AM
Post #2


Forum Member


Group: Admin
Posts: 660
Joined: 14-March 00
From: Wilmington, North Carolina
Member No.: 3



Hi Al,

The problem is with the image:

The image is a black and white image that was saved as a TRANSPARENT image. The black area (the text and lines) are transparent. Consequently, if you change the background color to white in PMView, it will look just like in IE, Mozilla, et al.

Change the background to black in Mozilla (don't know if you can do that) and it should look the same as in PMView.

IMHO the applications are doing everything right. The problem is with how the image was stored.

Re-save the image with PMView (disable transparency in the PNG options) and all will be fine.

Thanks,
Peter


--------------------
Peter Nielsen (peter@pmview.com) "If you can dream it, you can do it" JFK.
Go to the top of the page
 
+Quote Post
asavage
post Jun 9 2009, 11:48 AM
Post #3


Forum Member


Group: Members
Posts: 96
Joined: 6-August 00
From: Duvall, Washington USA
Member No.: 28



QUOTE (Peter @ Jun 9 2009, 09:13 AM) *
The problem is with the image:


Thanks for confirming that.

QUOTE
Re-save the image with PMView (disable transparency in the PNG options) and all will be fine.


I'm not a complete idiot -- some parts are missing!

I know where PNG options are, but am unsure how to "disable transparency". There appears to be several PNG options dealing with transparency, and I've managed to avoid knowing about them for all these years wink.gif

Do I want to merely uncheck "Write transparency chunk", as below?



--------------------
Regards, Duvall, WA
Al S. http://asavage.dyndns.org
Go to the top of the page
 
+Quote Post
Peter
post Jun 9 2009, 02:15 PM
Post #4


Forum Member


Group: Admin
Posts: 660
Joined: 14-March 00
From: Wilmington, North Carolina
Member No.: 3



QUOTE (asavage @ Jun 9 2009, 12:48 PM) *
Do I want to merely uncheck "Write transparency chunk", as below?


Correct! The default setting is "off", so if you never changed the settings in the past, you should not need to change them again.

A simple re-save of the image should take care of the problem.


--------------------
Peter Nielsen (peter@pmview.com) "If you can dream it, you can do it" JFK.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



Lo-Fi Version Time is now: 19th February 2018 - 08:19 PM