PMView.com

Welcome Guest ( Log In | Register )


hanno s
Posted on: Sep 13 2006, 08:08 AM


Forum Member


Group: Members
Posts: 4
Joined: 10-August 06
Member No.: 507


QUOTE (Peter @ Sep 8 2006, 04:41 PM) *
Try PMView 2000 and see if that solves the problem.

PMView v3.30 will revert to using integer math like PMView 2000 does. A step backwards in technology, but at least it will be fast on older computers too.

Thanks,
Peter


Hi,

now I have installed PMView 2000 (again wink.gif as I used it years before), and loading is much quicker!

QUOTE
A step backwards in technology, but at least it will be fast on older computers too.

I thought my Pent IV 3 GHz is not very old ... biggrin.gif biggrin.gif

So version 3.30 will solve the problem - that's great - and maybe will bring us some additional features like "cropping using a fixed aspect ratio" and "colormanagement (gamma, contrast, rbg) in one window".

Thanks a lot
Hanno
  Forum: PMView - OS/2 Technical Support · Post Preview: #1075 · Replies: 6 · Views: 28,843

hanno s
Posted on: Aug 31 2006, 11:11 AM


Forum Member


Group: Members
Posts: 4
Joined: 10-August 06
Member No.: 507


QUOTE (Peter @ Aug 27 2006, 07:46 PM) *
"Nothing" loads TIF faster than PMView. It sounds like you have a problem with your display driver.

Did you try to disable the "Progressive loading" option on the loading page? The eCS pictureviewer does not do progressive display. (Progressive display is about 10 times slower on some drivers).

Thanks,
Peter


Disabling "Progressive loading" does not change the behavior - pictures are displayed after rendering but the complete loading time is same. It's just a black screen instead of the progressiv display.

I use SNAP 3.1.7 prof., but also earlier versions did load faster. And I have done some test with the parameters for SNAP but without success.

Isn't it the same thing when you try to load a jpg-picture that has to be resized?

Thanks for your help
Hanno
  Forum: PMView - OS/2 Technical Support · Post Preview: #1072 · Replies: 6 · Views: 28,843

hanno s
Posted on: Aug 25 2006, 03:36 AM


Forum Member


Group: Members
Posts: 4
Joined: 10-August 06
Member No.: 507


QUOTE (Peter @ Aug 18 2006, 09:06 PM) *
Have you disabled the interpolation completely?

What CPU and speed are you using? The lastest versions of PMView are optimized for Pentium II and above. The JPEG codec works with floating point instead of integer arithmetic, and assembly code is removed to improve compatibity.

If loading feels too slow in PMView Pro, your best bet is probably to switch to PMView 2000 or upgrade to a faster CPU. (PMView 2000 uses integer arithmetic and some assembly to speed up JPEG reading).

Thanks,
Peter

Hi,

and thanks for your answer. I have disabled interpolation within the settings (is that "completely"?). But there is no significant change concerning the loadingtime. The difference between tif and jpg pictures is the same.

CPU speed is 3 GHz with an Intel Pent. IV, 1 GB memory

>probably to switch to PMView 200
Do you mean the old version of PMView? Should this be faster?

But again: The eCS-pictureviewer load tif and jpg faster, both with SAME speed.

Thanks in advance for your help
Hanno

PS: I am sure you are able to reproduce this problem: Compare loadingtime for 2000x3000, 6Mb JPG-pictures with 2000x30000, 17Mb TIFF-pictures.
  Forum: PMView - OS/2 Technical Support · Post Preview: #1069 · Replies: 6 · Views: 28,843

hanno s
Posted on: Aug 11 2006, 10:15 AM


Forum Member


Group: Members
Posts: 4
Joined: 10-August 06
Member No.: 507


Hi,

and first of all many thanks to Peter for his great program for OS/2 and eCS.

I would like to ask, if there is a possibility to speed up loading of JPG-files?

JPG-pictures (size 2016x3024, about 2,3 MB) need about 8 s to load.
The same picture as TIFF (17,4 MB) needs less than 1 s.

Also the OS/2 built-in picture-viewer loads much faster than PMView.

Because of the picturesize, PMView has to shrink the picture to 40% to display. If no zooming is used, loading is faster.
(There is no interpolation).

Any hints?

Kind regards
Hanno
  Forum: PMView - OS/2 Technical Support · Post Preview: #1063 · Replies: 6 · Views: 28,843


New Posts  New Replies
No New Posts  No New Replies
Hot topic  Hot Topic (New)
No new  Hot Topic (No New)
Poll  Poll (New)
No new votes  Poll (No New)
Closed  Locked Topic
Moved  Moved Topic
 

Lo-Fi Version Time is now: 16th October 2018 - 11:57 AM